Service Outage: BJC Phone System Issues at St. Louis Childen's Hospital
Incident Report for Washington University - IT
Resolved
BJC has resolved the phone system issues affecting SLCH users. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Nov 20, 2020 - 10:38 CST
Update
BJC and WashU Technical teams are investigating phone system issues at St. Louis Children's Hospital. A change was performed last night as part of migrating some old equipment. Possibly as a result, multiple unanticipated issues have occurred, including unavailability of the main Supply number. Technical teams have resolved most or all of the issues and are confirming with users now.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions (using an alternate phone option). We appreciate your patience as we work to restore service.
Posted Nov 20, 2020 - 10:17 CST
Update
BJC and WashU Technical teams are investigating phone system issues at St. Louis Children's Hospital. A change was performed last night as part of migrating some old equipment. Possibly as a result, multiple unanticipated issues have occurred, including unavailability of the main Supply number. Technical teams continue to troubleshoot the reported issues and will provide additional updates within the next 30 minutes.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions (using an alternate phone option). We appreciate your patience as we work to restore service.
Posted Nov 20, 2020 - 09:54 CST
Investigating
BJC and WashU Technical teams are investigating phone system issues at St. Louis Children's Hospital. A change was performed last night as part of migrating some old equipment. Possibly as a result, multiple unanticipated issues have occurred, including unavailability of the main Supply number.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions (using an alternate phone option). We appreciate your patience as we work to restore service.
Posted Nov 20, 2020 - 09:21 CST
This incident affected: BJC Devices and Services (BJC Phone System).