Vended Service Outage: BJC Outbound Telephony
Incident Report for Washington University - IT
Resolved
BJC IT and the vendor have resolved the issue. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Nov 28, 2022 - 16:38 CST
Investigating
BJC IT is investigating a vendor issue with errors in outbound calling.

BJC and the vendor are working to resolve the issue. Please call 314-933-3333 if you have any questions.

We appreciate your patience as BJC works to restore service.
Posted Nov 28, 2022 - 11:16 CST
This incident affected: BJC Devices and Services (BJC Phone System).