Service Outage: BJC Phone Issues - MBMC
Incident Report for Washington University - IT
Resolved
BJC and AT&T have resolved the issue which was affecting the phone system at MBMC. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Sep 10, 2020 - 03:50 CDT
Update
BJC Technical Teams are investigating phone system issues which are affecting Missouri Baptist Medical Center. AT&T is on-site working on the problem and has restored outbound calling. Inbound calling is still being investigated. AT&T has identified some equipment on-site which is powered off and they are investigating this as a possible root cause of the phone system issues.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Sep 10, 2020 - 02:33 CDT
Update
BJC Technical Teams are investigating phone system issues which are affecting Missouri Baptist Medical Center. AT&T is on-site working on the problem and has restored outbound calling. Inbound calling is still being investigated. The support ticket is being escalated with AT&T.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Sep 10, 2020 - 01:40 CDT
Update
BJC Technical Teams are investigating phone system issues which are affecting Missouri Baptist Medical Center. AT&T is on-site working on the problem and has restored outbound calling. Inbound calling is still being investigated.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Sep 10, 2020 - 00:49 CDT
Update
BJC Technical Teams are investigating phone system issues which are affecting Missouri Baptist Medical Center (initially BJWC was included but has since been confirmed unaffected). Affected phones are experiencing fast busy signals and are unable to place or receive calls. A support ticket has been opened with AT&T and an engineer has been dispatched to the site.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Sep 09, 2020 - 23:58 CDT
Update
BJC Technical Teams are investigating phone system issues which are affecting Missouri Baptist Medical Center (initially BJWC was included but has since been confirmed unaffected). Affected phones are experiencing fast busy signals and are unable to place or receive calls. A support ticket has been opened with AT&T.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Sep 09, 2020 - 23:20 CDT
Investigating
BJC Technical Teams are investigating phone system issues which are affecting Missouri Baptist Medical Center and Barnes Jewish West County Hospital. Affected phones are experiencing fast busy signals and are unable to place or receive calls. A support ticket has been opened with AT&T.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Sep 09, 2020 - 22:56 CDT
This incident affected: BJC Devices and Services (BJC Phone System).