Service Degradation: Microsoft Teams Delays
Incident Report for Washington University - IT
Resolved
Microsoft has resolved the delays in Teams message delivery. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Feb 17, 2021 - 20:47 CST
Identified
Microsoft continues to work the issue by re-routing services to alternate infrastructure.

Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Feb 17, 2021 - 14:56 CST
Investigating
WashU IT is investigating an issue with Microsoft Teams messages being delayed.

Microsoft is working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Feb 17, 2021 - 11:35 CST
This incident affected: Communications & Collaboration (Microsoft Teams).