Service Outage: Webclock giving SQL errors
Incident Report for Washington University - IT
Resolved
WashU IT Engineers have resolved the issues affecting clocking in after a meal break in Webclock. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Nov 23, 2020 - 18:37 CST
Identified
WashU IT is investigating an issue with Webclock. A change was processed over the weekend to fix an issue with meal breaks, and an unintended side effect of that change affected clocking in from meal breaks. Employees can clock in normally, and can clock out normally, but may not be able to clock back in from a meal break. When someone attempts to clock back in from a meal break between 28-32 min of the hour, or 58-02 min, they will get a SQL error. An emergency change is scheduled for 6pm tonight and testers are on standby.

Users who are unable to clock back in from a meal break should record the clock in time and provide it to their manager, so it can be manually recorded in the webclock system once this issue has been resolved.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Nov 23, 2020 - 13:47 CST
Investigating
WashU IT is investigating an issue with Webclock. A change was processed over the weekend to fix an issue with meal breaks, and an unintended side effect of that change affected clocking in from meal breaks. Employees can clock in normally, and can clock out normally, but may not be able to clock back in from a meal break. When someone attempts to clock back in from a meal break between 28-32 min of the hour, or 58-02 min, they will get a SQL error. An emergency change is scheduled for 6pm tonight and testers are on standby.

Users who are unable to clock back in from a meal break should record the clock in time and provide it to their manager, so it can be manually recorded in the webclock system once this issue has been resolved.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Nov 23, 2020 - 13:39 CST