Vender Service Outage: Utility Power Outage Affecting Residential Buildings
Incident Report for Washington University - IT
Resolved
Ameren has resolved the power outage affecting the residential campus. All network services have been restored. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Jun 22, 2022 - 08:12 CDT
Monitoring
WashU IT is aware of a significant Ameren outage which has resulted in the loss of power and network services in campus residential buildings. Ameren is aware of the issue and has provided an ETA of 12-24 hours or more.

Ameren is working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as Ameren works to restore service.
Posted Jun 21, 2022 - 18:28 CDT
This incident affected: Network & Connectivity (Network Services).