Service Outage: ECV Login Remote Desktop Error
Incident Report for Washington University - IT
Resolved
The Epic One team has identified the issue affecting ECV connections and has restored service. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Oct 05, 2021 - 12:42 CDT
Investigating
EPIC One is investigating an issue affecting ECV logins. ECV users are getting an error:

"The task you are trying to do can't be completed because Remote Desktop Services is currently busy. Please try again in a few minutes. Other users should still be able to log on."

BJC technical teams are working to resolve the issue and have put a potential fix in place. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Oct 05, 2021 - 10:26 CDT
This incident affected: BJC Devices and Services (BJC Enterprise Client Virtualization (ECV)).