Service Outage Advisory: Zoom Meeting Issues
Incident Report for Washington University - IT
Resolved
Zoom Support has confirmed that they resolved the issues affecting some users joining Zoom meetings.

If you experience further issues, please contact us at 314-933-3333.
Posted Nov 17, 2020 - 11:19 CST
Investigating
Zoom Support has published a notification that some users may be experiencing difficulties joining Zoom meetings right now. More details will be provided once they become available.

Please call 314-933-3333 if you have any questions.
Posted Nov 17, 2020 - 10:56 CST
This incident affected: Communications & Collaboration (Zoom).