BJC Service Outage: Partial Network Outage - Memorial Hospital
Incident Report for Washington University - IT
Resolved
BJC IT Engineers have resolved the issue with network services. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Nov 30, 2022 - 14:56 CST
Update
BJC IT is aware of a brief issue that occurred with 3rd floor services as well.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Nov 30, 2022 - 14:31 CST
Investigating
BJC IT is investigating an issue with network and phone services on the second floor of Memorial Hospital East. BJC is working to resolve the issue.

Please call 314-933-3333 if you have any questions. We appreciate your patience as BJC works to restore service.
Posted Nov 30, 2022 - 10:34 CST
This incident affected: BJC Devices and Services (BJC Network Connectivity).