Service Outage: eFax
Incident Report for Washington University - IT
Resolved
WashU IT Engineers have resolved the outage with eFax preventing inbound faxing to internal numbers. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Nov 23, 2020 - 14:24 CST
Update
We are continuing to investigate this issue.
Posted Nov 23, 2020 - 13:49 CST
Investigating
WashU IT is investigating an issue with eFax. Inbound faxes to on-prem numbers are not arriving. Cloud numbers appear to be working. Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Nov 23, 2020 - 13:47 CST
This incident affected: Computing and Printing (E-Fax).