Service Outage Advisory: Screening.wustl.edu Inaccessible to On-Campus Users
Incident Report for Washington University - IT
Resolved
WashU IT Engineers have resolved the connectivity issues which were affecting the Covid screening site. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted May 11, 2021 - 18:46 CDT
Update
WashU IT has identified an issue with the Covid screening site (screening.wustl.edu) being inaccessible to users accessing the site from the WashU campus. This site is hosted by Google and supported by a third party vendor. WashU IT technical teams continue to troubleshoot the issue in conjunction with the vendor.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions.
Posted May 11, 2021 - 18:10 CDT
Investigating
WashU IT has identified an issue with the Covid screening site (screening.wustl.edu) being inaccessible to users accessing the site from the WashU campus. This site is hosted by Google and supported by a third party vendor. WashU IT technical teams are contacting the vendor to offer assistance.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions.
Posted May 11, 2021 - 16:36 CDT
This incident affected: Cloud Services (Google).