Service Outage - High Severity: Credit Card Transaction Processing @ Multiple Clinic Locations

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have confirmed that Bank of America has resolved their service outage, and credit card transactions are processing successfully at affected clinic locations. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Jan 09, 2026 - 09:29 CST

Update

WashU IT is investigating reports that credit card transactions are failing at multiple clinic locations. Our credit card processing vendor (Bank of America) has confirmed a service outage on their side and we are waiting for confirmation that they've resolved the issue.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jan 09, 2026 - 09:21 CST

Identified

WashU IT is investigating reports that credit card transactions are failing at multiple locations. Our credit card processing vendor (Bank of America) has confirmed a service outage on their side and is working to identify the root cause.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jan 09, 2026 - 09:03 CST

Investigating

WashU IT is investigating reports that credit card transactions are failing at multiple locations. Technical teams have reached out to the processing institution to identify root cause.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jan 09, 2026 - 08:57 CST
This incident affected: Clinical Applications (Credit Card and Payment Processing).