Service Outage - High Severity: Cloudflare Global Services

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have confirmed that Cloudflare resolved their service outage. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Nov 18, 2025 - 08:59 CST

Investigating

WashU IT has received notification that WashU users are experiencing issues with OnBase and various WashU websites. The root cause is a Cloudflare vendor service outage, which the vendor is in the process of resolving. Please reference their status page for additional details: https://www.cloudflarestatus.com/

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Nov 18, 2025 - 07:37 CST
This incident affected: Vendor Service.