Vendor Service Outage: Canvas

Incident Report for Washington University - IT

Resolved

This incident has been resolved.
Posted Nov 07, 2025 - 12:38 CST

Monitoring

A fix has been implemented by the vendor and WashU is monitoring the results.

More details can be found at https://status.instructure.com/
Posted Nov 07, 2025 - 11:26 CST

Investigating

Canvas is currently experiencing an issue that is affecting multiple customers including WashU.

Instructure is aware of the issue and working to resolve it.

More details can be found at https://status.instructure.com/
Posted Nov 07, 2025 - 10:46 CST
This incident affected: Teaching & Learning (Canvas).