BJC Service Outage: WellSky

Incident Report for Washington University - IT

Resolved

This incident has been resolved.
Posted Jan 02, 2026 - 15:17 CST

Update

BJC is monitoring for additional issues.
Posted Jan 02, 2026 - 14:37 CST

Monitoring

BJC IT experienced a disruption to the WellSky application this afternoon.

Services appear to be recovering and BJC Teams are monitoring platform health.
Posted Jan 02, 2026 - 14:36 CST
This incident affected: BJC Devices and Services (BJC Clinical Applications).