Service Outage (Vendor) - High Severity: 969 Mason Network Connection Slow

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have worked with our vendor to upgrade the 969 Mason site's backup AT&T connection, and normal operations have been restored. Technical teams will continue to work with Charter Spectrum to bring service back up on the primary connection.

We appreciate your patience during this incident.
Posted Jun 13, 2025 - 15:26 CDT

Investigating

WashU IT is investigating an issue with the network connection at 969 Mason. The site has lost their primary Charter Spectrum connection and is functional but slow on their backup AT&T connection. A support case has been opened with Charter Spectrum to investigate the issue.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jun 13, 2025 - 13:14 CDT
This incident affected: Network & Connectivity (Vendor Services (Spectrum, AT&T, etc.)).