WashU IT and BJC engineers have done extensive troubleshooting throughout the day but have not yet determined a confirmed root cause. We have not continued receiving additional reports of the issue. The Major Incident will remain open in Monitoring status until mid-day tomorrow (Wednesday 8/19) while technical teams monitor for additional issues.
Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Aug 18, 2026 - 14:25 CDT
Update
WashU IT and BJC engineers continue to troubleshoot issues affecting the Citrix icon.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Aug 18, 2026 - 11:28 CDT
Update
WashU IT and BJC engineers continue to investigate reports that users are trying to open Citrix and are not getting the expected response when they click on the icon.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Aug 18, 2026 - 11:09 CDT
Investigating
WashU IT is investigating reports that users are trying to open Citrix and are not getting the expected response when they click on the icon. Reinstalling Citrix is resolving the issue in some cases.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Aug 18, 2026 - 09:32 CDT
This incident affects: Clinical Applications (ECV (Enterprise Client Virtualization)).