BJC IT has resolved the issue affecting Pyxis. Pyxis Med Stations are back up and running. Orders and ADT (admissions, discharges, transfers) are transmitting to Pyxis real time.
If you continue to experience further issues, please contact us at 314-933-3333. We appreciate your patience during this incident.
Posted Aug 18, 2025 - 18:04 CDT
Investigating
BJC IT is aware that Pyxis med stations across the East region are functioning in “Critical Override” mode. New medication orders are not available in Pyxis. Any patient movement (ADT) that occurs after the beginning of the outage will not be in Pyxis (new admissions, transfers, discharges).
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Aug 18, 2025 - 16:47 CDT
This incident affected: BJC Devices and Services (BJC Clinical Applications).