Service Outage: MECM Tools

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have resolved the issue with MECM.
Posted Jul 29, 2025 - 10:17 CDT

Identified

Washington University IT has identified an issue with MECM tools affecting PC imaging and application updates. There is no customer impact at this time.

Teams are working to resolve the issue.

Please call 314-933-3333 if you have any questions.
Posted Jul 29, 2025 - 08:56 CDT