Charter Spectrum has repaired the fiber cut and network connectivity has been restored
Posted Jul 03, 2025 - 14:36 CDT
Update
WashU IT is investigating an issue with network service being unavailable at 1234 South Kingshighway. Spectrum has identified that the site was impacted by a fiber cut and has begun repairs.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jul 03, 2025 - 09:48 CDT
Investigating
WashU IT is investigating an issue with network service being unavailable at 1234 South Kingshighway. Charter Spectrum has emergency maintenance in progress for this site and is expecting service to be restored by approximately 7am. This site is listed as having approximately 130 users.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.