BJC Technical teams have resolved the issues affecting calls to ASCOM calls at Belleville Memorial and Shiloh. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
Posted Nov 12, 2024 - 16:07 CST
Identified
BJC continues to troubleshoot issues with making calls from or transferring calls to patient ASCOM phones at both Belleville Memorial and Shiloh BJC locations. A possible root cause has been identified, and technical teams are working with the vendor to implement a fix.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Nov 12, 2024 - 13:35 CST
Investigating
BJC has started a P1 call for issues with making calls from or transferring calls to patient ASCOM phones at both Belleville Memorial and Shiloh BJC locations.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Nov 12, 2024 - 12:46 CST
This incident affected: BJC Devices and Services (BJC Phone System).