Partial Power Outage - 276 Skinker

Incident Report for Washington University - IT

Resolved

The power issue affecting Marketing and Communications services has been resolved. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Jun 04, 2025 - 08:48 CDT

Monitoring

WashU IT is aware of a power outage affecting portions of the 276 Skinker building. WashU IT network services are up and running, but some Marketing and Communications sites may be unavailable due to power affecting areas of the building that host those servers.

Facilities is working to resolve the power issue.

Please contact us at 314-933-3333 if you have any questions.
Posted Jun 03, 2025 - 17:06 CDT
This incident affected: University Websites (Externally Hosted Websites).