BJC Wireless Outage - Central West End Campus

Incident Report for Washington University - IT

Resolved

All services have been restored.

BJC and WashU will continue to monitor service health.
Posted Oct 21, 2025 - 16:01 CDT

Monitoring

A fix has been implemented.

Teams are monitoring service health.
Posted Oct 21, 2025 - 15:28 CDT

Update

BJC continues to troubleshoot the issue which appears to be hardware-related.

Eduroam services are also impacted in some buildings on the Central West End Campus.
Posted Oct 21, 2025 - 15:00 CDT

Investigating

BJC is currently experiencing a disruption to WiFi services that includes WashU WUSM-Secure in some buildings on the Central West End Campus.

BJC is aware of the issue and working to resolve it.
Posted Oct 21, 2025 - 14:34 CDT
This incident affected: BJC Devices and Services (BJC Network Connectivity).