Service Outage - High Severity: Archibus Not Retaining Data
Incident Report for Washington University - IT
Resolved
WashU IT Engineers have resolved the issue affecting Archibus. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Mar 11, 2024 - 14:13 CDT
Investigating
WashU IT is investigating an issue with Archibus not retaining data.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Mar 11, 2024 - 13:27 CDT
This incident affected: Administrative & Enterprise Systems (Archibus).