Vendor Service Outage: Charter Spectrum Internet

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have confirmed that affected Spectrum internet service has been restored. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Feb 06, 2025 - 13:47 CST

Update

WashU IT has received reports that Charter Spectrum is experiencing a service outage. Users are still calling the Service Desk regarding internet connectivity issues, indicating that Spectrum has not fully resolved the issue.

Please call 314-933-3333 if you have any questions. We appreciate your patience during this incident.
Posted Feb 06, 2025 - 11:33 CST

Investigating

WashU IT has received reports that Charter Spectrum is experiencing a service outage. Users in the St. Louis area are having internet connectivity issues, affecting VPN connections and access to other websites (both WashU and non-WashU). The vendor is working to restore service.

Please call 314-933-3333 if you have any questions. We appreciate your patience during this incident.
Posted Feb 06, 2025 - 08:32 CST
This incident affected: Network & Connectivity (Vendor Services (Spectrum, AT&T, etc.)).