Service Outage - High Severity: Unable to Connect to RMS

Incident Report for Washington University - IT

Resolved

WashU IT Engineers and the vendor have resolved the issue affecting the RMS platform and service has been restored. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Jan 05, 2026 - 14:55 CST

Investigating

WashU IT is investigating an issue with the RMS platform. Users are unable to connect and are receiving error messages. This appears to be a reoccurrence of an issue which previously occurred on 12/30. Technical teams are opening a support case with the vendor.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jan 05, 2026 - 14:09 CST
This incident affected: Research (RMS (Research Management System)).