Service Outage - High Severity: Ameren Power Outages @ Danforth/South 40

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have confirmed that power has been restored to all affected locations. Network services have recovered at all locations except one (Rebstock), which has a network device which will need additional troubleshooting. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Nov 01, 2025 - 16:10 CDT

Investigating

WashU IT is aware of power outages at multiple locations on the Danforth and South 40 campuses. The majority of the impacted locations have already recovered, but the South 40 location is still without power. Ameren is aware of the outages and we expect power to fully restored by 4-4:30pm.

Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Nov 01, 2025 - 15:42 CDT
This incident affected: Facilities.