Service Outage - High Severity: ECV Login Issues

Incident Report for Washington University - IT

Resolved

WashU IT Engineers identified two separate issues affecting ECV logins. One issue was already resolved by BJC ECV engineers, and the other only affects a small group of contingent workers. The major incident has been concluded. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted May 18, 2026 - 09:38 CDT

Investigating

WashU IT is investigating reports of ECV login issues (may be reported as Epic login issues). We are engaging BJC technical teams for additional assistance.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted May 18, 2026 - 09:07 CDT
This incident affected: Clinical Applications (ECV (Enterprise Client Virtualization)).