Service Outage - High Severity: Northwest Tower Network Connectivity

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have resolved the network connectivity issues affecting Northwest Tower. The issue is believed to be due to a software bug on a network switch. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Jun 30, 2025 - 13:18 CDT

Update

WashU IT is investigating reports of network connectivity issues in multiple floors of Northwest Tower. Technical teams are still troubleshooting the issue and will be opening a support case with the vendor for additional assistance.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jun 30, 2025 - 12:08 CDT

Update

WashU IT is investigating reports of network connectivity issues in multiple floors of Northwest Tower. The issue has been partially diagnosed and resolved; however, some users may still be impacted. Troubleshooting continues.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jun 30, 2025 - 11:14 CDT

Investigating

WashU IT is investigating reports of network connectivity issues in multiple floors of Northwest Tower. The symptoms are wired internet connections intermittently disconnecting. The issue appears initially to be different from the issue reported earlier this morning and is being considered a new major incident at this time.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jun 30, 2025 - 10:29 CDT
This incident affected: Network & Connectivity (Network Services).