Service Outage (Vendor) - High Severity: Microsoft 365

Incident Report for Washington University - IT

Resolved

Microsoft's latest update is that the Microsoft 365 issue is resolved. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Jan 21, 2026 - 13:40 CST

Update

WashU IT is investigating reported issues with degraded performance in Teams calls for some users. Microsoft has investigated possible service issues with Office 365 and Teams and believes they were caused by network issues outside of their services. Please refer to their service portal for more information: https://status.cloud.microsoft/m365/referrer=serviceStatusRedirect.

Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jan 21, 2026 - 11:54 CST

Investigating

WashU IT has received notification from Microsoft that they are experiencing a service issue affecting 365 service, including Teams and Office. Please refer to their service portal for more information: https://status.cloud.microsoft/m365/referrer=serviceStatusRedirect.

Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jan 21, 2026 - 11:32 CST
This incident affected: Communications & Collaboration (Office 365, Microsoft Teams).