Service Outage - High Severity: North Building Network Connectivity

Incident Report for Washington University - IT

Resolved

WashU IT is canceling the major incident for this location. Services are currently online and functional, and the network team will investigate what caused the initial disruption. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Jun 19, 2025 - 10:28 CDT

Investigating

WashU IT is investigating reports of network connectivity issues at North Building, Basement Room 3. Users are reporting issues with wired and wireless network connections, automated controls, and Metasys login is failing.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jun 19, 2025 - 10:15 CDT
This incident affected: Network & Connectivity (Network Services).