Service Outage - Low Severity: Multiple Printers Not Working @ BJC West County POB4

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have resolved the issue affecting printing at the POB4 location. A configuration issue was identified and rectified, after which the printers began responding and print jobs started processing. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Nov 21, 2025 - 15:26 CST

Investigating

WashU IT is investigating an issue with several WashU printers in BJC West County POB4, suites 110 and 210. A configuration change implemented on 11/20 appears to have caused a disruption in services.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Nov 21, 2025 - 13:05 CST
This incident affected: Computing and Printing (PaperCut Printing).