Service Outage - Low Severity: Printers Dropping Network Connection @ OTM

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have resolved the issues affecting printers at OTM. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Apr 01, 2025 - 16:57 CDT

Investigating

WashU IT is investigating an issue with printers intermittently dropping their network connections at the OTM (Office of Technology Management) at 4240 Duncan. The issue is believed to be related to recent network changes on or around 3/27/25.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Apr 01, 2025 - 15:32 CDT
This incident affected: Network & Connectivity (Network Services).