Vendor Service Outage: Credit Card Processing

Incident Report for Washington University - IT

Postmortem

A post-incident report is now available for this incident.

https://wustl.box.com/s/7rl8wewi2smh0q364mobxf7irjtxtmtx

Posted May 29, 2026 - 11:03 CDT

Resolved

WashU IT Engineers has received confirmation that Bank of America has resolved their service outage. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted May 28, 2026 - 14:30 CDT

Investigating

WashU IT has received notification that Bank of America is experiencing a service issue which affects WashU clinics' ability to process credit card transactions.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted May 28, 2026 - 12:48 CDT
This incident affected: Clinical Applications (Credit Card and Payment Processing).