WashU IT Engineers have resolved the issues affecting network services on Danforth campus. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
Posted May 18, 2026 - 19:26 CDT
Monitoring
WashU IT has introduced a possible fix for the issue affecting network services on Danforth campus. Teams are monitoring for remaining impact. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
Posted May 18, 2026 - 18:37 CDT
Update
WashU IT is investigating network connectivity issues with multiple locations on the Danforth Campus and S40. Impacted locations include:
North Brookings Thomas Elliot Weil Hall Lien Lewis Dauten Shandeling Rutledge Givens Umrath Lee Park Mudd Core 717 Core 818 WUPD
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted May 18, 2026 - 18:24 CDT
Investigating
WashU IT is investigating alerts for a large number of Danforth campus devices which appear to have briefly lost network connectivity. Many devices have already recovered, but some are intermittent or have not come back online. Technical teams and Facilities are working to verify what the actual impact is and will provide additional details in another update.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted May 18, 2026 - 17:36 CDT
This incident affected: Network & Connectivity (Wired Network Services) and Facilities - Power, Water, Etc.