Partial Service Outage: South County Pediatrics
Incident Report for Washington University - IT
Resolved
WashU IT Engineers have resolved the issue.

If you continue to experience further issues, please contact us at 314-933-3333. We appreciate your patience during this incident.
Posted Jan 13, 2025 - 10:43 CST
Identified
Washington University IT has identified a network issue at South County Pediatrics at 4850 Lemay Ferry Road.

Teams are working to resolve the issue.

Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jan 13, 2025 - 09:47 CST
This incident affected: Network & Connectivity (Network Services).