BJC Outage - Outbound Phone Calls From Certain Locations

Incident Report for Washington University - IT

Resolved

This incident has been resolved.
Posted Nov 21, 2025 - 09:37 CST

Investigating

WashU IT is aware of an BJC outage affecting outbound calling from the below locations.

Internal and station to station calling is not affected.

Barnes-Jewish Hospital North
Barnes-Jewish Hospital South
St. Louis Children's Hospital

BJC is working to resolve the issue.
Posted Nov 21, 2025 - 07:53 CST
This incident affected: BJC Devices and Services (BJC Telephony and Fax).