Partial Service Outage: PaperCut Print Deploy, Admin Interface
Incident Report for Washington University - IT
Resolved
WashU IT Engineers have resolved the issue. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Apr 24, 2024 - 18:00 CDT
Monitoring
WashU IT has introduced a fix for all PaperCut features except for Multifunction print release.

Teams are continuing to monitoring the service recovery sync for MFP, which is expected to take another 3 hours.
Posted Apr 24, 2024 - 14:35 CDT
Investigating
WashU IT is aware of an issue affecting PaperCut Print Deploy, and the PaperCut administrative interface.

Some users may not have access to some print queues or the admin interface.
Posted Apr 24, 2024 - 13:26 CDT
This incident affected: Computing and Printing (PaperCut Printing).