Vendor Service Advisory: Spectrum Service at Multiple Clinics

Incident Report for Washington University - IT

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 09:07 CDT

Update

All services have been restored.
Posted Mar 17, 2025 - 08:09 CDT

Update

Power has been restored to the clinic. Techs are on site and waiting for office staff to grant entry.
Posted Mar 17, 2025 - 07:46 CDT

Update

All sites have recovered except 8790 Watson Road. The issue is believed to be related to ongoing power outages in the area.

Team members will be on site at the start of business tomorrow to gain access and coordinate any IT assistance if power is available.
Posted Mar 16, 2025 - 19:58 CDT

Monitoring

Following the severe weather incident last night, 5 remote clinics are without Spectrum Service. The clinics are currently closed. Spectrum is aware of each and working to resolve the issues.

• Crestwood Eye Clinic
• Eye Center and LASIK Surgery Center
• Surgery Heart and Vascular
• Village Square Dialysis, Pharm, Social Services
• WUCA Suburban Pediatrics
Posted Mar 15, 2025 - 16:07 CDT
This incident affected: Network & Connectivity (Vendor Services (Spectrum, AT&T, etc.)).