BJC Service Outage: PYXIS
Incident Report for Washington University - IT
Resolved
The vendor has resolved the issues with PYXIS.

If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Apr 05, 2024 - 10:49 CDT
Monitoring
The vendor has introduced a possible fix for the issues with PYXIS.

Teams are continuing to monitor the service to validate the fix.

We appreciate your patience during this incident.
Posted Apr 05, 2024 - 10:19 CDT
Investigating
WashU IT aware of an issue with the BJC PYXIS application.

BJC is working to resolve the issue. Please call 314-933-3333 if you have any questions.

We appreciate your patience as BJC works to restore service.
Posted Apr 05, 2024 - 08:33 CDT
This incident affected: BJC Devices and Services (BJC Clinical Applications).