Service Outage - Low Severity: Employee Bearbucks Accounts

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have resolved the issue affecting Bear Bucks access. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Aug 16, 2025 - 12:37 CDT

Investigating

WashU IT is investigating an issue with a number of employees who have lost access to their Bearbucks accounts. Impacted individuals will be unable to use pre-loaded Bearbucks funds nor use their payroll deduction if they have set that up.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Aug 16, 2025 - 10:14 CDT
This incident affected: Administrative & Enterprise Systems (Bear Bucks).