Vendor Service Outage: Ameren Power @ VSC (Village Square Hazelwood)

Incident Report for Washington University - IT

Resolved

Ameren has restored power to the VSC site. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Jun 17, 2026 - 12:32 CDT

Identified

WashU IT has been notified that Ameren is experiencing a service outage affecting VSC (Village Square Hazelwood). The site is currently up on a backup generator and our network equipment is still online. Most phones are working and users are able to charge devices via outlets connected to the backup generator.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jun 17, 2026 - 12:03 CDT
This incident affected: Facilities - Power, Water, Etc.