Service Outage - High Severity: Workday Login Failing

Incident Report for Washington University - IT

Resolved

WashU IT Engineers identified an issue on one of the Workday servers and removed it from rotation. Users are now able to log into Workday successfully. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Jan 19, 2026 - 13:56 CST

Update

We are continuing to investigate this issue.
Posted Jan 19, 2026 - 13:32 CST

Investigating

WashU IT is investigating an issue with users being unable to log into Workday and possibly giving a password error.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jan 19, 2026 - 13:13 CST
This incident affected: Administrative & Enterprise Systems (Workday).