Vendor Service Outage Advisory: Box Storage Logins
Incident Report for Washington University - IT
Resolved
Box Storage support has resolved the issue affecting Box logins. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Mar 07, 2024 - 18:29 CST
Investigating
Box Storage support has posted a notification on their Statuspage (https://status.box.com/) stating that they are experiencing service issues:

"Investigating - Our team is investigating an issue with Logins within Box. Users attempting to log in to Box may see errors or timeouts. We will provide additional information as it becomes available
Mar 07, 2024 - 13:36 PST"

Please call 314-933-3333 if you have any questions.
Posted Mar 07, 2024 - 15:41 CST
This incident affected: Communications & Collaboration (Box File Storage System).