WashU IT Engineers has received notification from the vendor that Monday.com services have been restored. If you continue to experience further issues, please contact us at 314-933-3333.
We appreciate your patience during this incident.
Posted Aug 04, 2025 - 10:54 CDT
Update
WashU IT has received reports that the Monday.com project management site is experiencing a service issue. There are indications that services are recovering, but the vendor has not yet sent a resolution notification. Please refer to https://status.monday.com/ for additional details.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Aug 04, 2025 - 10:03 CDT
Investigating
WashU IT has received reports that the Monday.com project management site is experiencing a service issue. This is a cloud-based vendor service and the vendor is working on addressing the issue. Users may be unable to log into the site or may be disconnected if they were already logged in. Please refer to https://status.monday.com/ for additional details.
Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Aug 04, 2025 - 08:03 CDT
This incident affected: University Websites (Externally Hosted Websites).