Service Outage Advisory: Interfolio Intermittent Unavailability

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have confirmed that Interfolio services have stabilized. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Nov 18, 2025 - 14:33 CST

Investigating

WashU IT has received confirmation that the Interfolio vendor is currently experiencing a service issue as a result of Cloudflare issues earlier in the day. Interfolio users are able to log into the system, but pages are intermittently not loading, and users may not be able to attach files or complete forms.

Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Nov 18, 2025 - 11:40 CST
This incident affected: Vendor Service.