Service Outage - Low Severity: Becker.wustl.edu Medical Library Site Unavailable

Incident Report for Washington University - IT

Resolved

WashU IT Engineers have resolved the issue affecting becker.wustl.edu. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Nov 03, 2025 - 11:27 CST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 03, 2025 - 11:10 CST

Investigating

WashU IT is investigating an issue with the Becker Medical Library website, becker.wustl.edu. The server for the site is still working, but the website to access it is returning connection errors.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Nov 03, 2025 - 08:43 CST
This incident affected: University Websites (WashU IT Hosted Websites).