Service Advisory - 1RAD Sectra Upgrade To BJC Servers

Incident Report for Washington University - IT

Postmortem

A post-incident report is now available for this incident:

https://wustl.box.com/s/g0d7l3h8lc46xaxa8vt6sr8h6nthi8xm

Posted Jul 03, 2025 - 07:08 CDT

Resolved

WashU IT Engineers have mitigated the impact by deploying an update and providing instructions.

If you continue to experience further issues, please contact us at 314-933-3333.
Posted Jun 24, 2025 - 08:37 CDT

Identified

WashU IT is aware of an issue impacting users of Sectra.

Some users are unable to access Sectra following a recent upgrade to the platform.

WashU IT will be sending out an update to known users of Sectra and providing instructions for self-service.
Posted Jun 21, 2025 - 21:34 CDT
This incident affected: BJC Devices and Services (BJC Clinical Applications).