Service Outage: Microsoft Services

Incident Report for Washington University - IT

Resolved

Microsoft has indicated that services across the affected regions have largely recovered.

They will be working on any residual impact and monitoring the situation into the morning hours.

We appreciate your patience as Microsoft worked to restore service.
Posted Oct 29, 2025 - 22:03 CDT

Monitoring

Microsoft has restored most services and has provided an estimate of 7:40 PM CDT for full restoration.
Posted Oct 29, 2025 - 18:46 CDT

Identified

Microsoft has identified the issue and implemented a corrective change.

Some services are showing signs of recovery but no official ETA has been provided by the vendor.
Posted Oct 29, 2025 - 14:44 CDT

Investigating

WashU IT is aware of a national Microsoft issue affecting multiple services, including Exchange/Outlook, Teams, SharePoint, Azure, and other 365 services.

Microsoft is aware of the issue and is implementing measures to resolve the issue.
Posted Oct 29, 2025 - 12:23 CDT
This incident affected: Communications & Collaboration (Email, Office 365, Microsoft Teams, Zoom).