BJC Service Outage: Forms on Demand Not Printing
Incident Report for Washington University - IT
Resolved
BJC Technical teams have resolved the issue with Forms on Demand printing. If you continue to experience further issues, please contact us at 314-933-3333.

We appreciate your patience during this incident.
Posted Jul 18, 2021 - 09:44 CDT
Investigating
BJC Technical teams are investigating an issue affecting Forms on Demand at multiple locations. Users are reporting problems with printing arm bands and documents. A support case has been opened with the vendor.

Teams are working to resolve the issue. Please call 314-933-3333 if you have any questions. We appreciate your patience as we work to restore service.
Posted Jul 18, 2021 - 08:12 CDT
This incident affected: BJC Devices and Services (BJC Clinical Applications).